HUIT Service Status Dashboard

External Email Delays

Incident Report for HUIT

Resolved

The external email issue has been resolved, and messages from external addresses should now be received successfully. If you experience any issues receiving email, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Aug 14, 2026 - 12:00 EDT

Investigating

We are currently experiencing potential delays with external email delivery. Messages sent from addresses outside our organization may take longer than usual to arrive.

Internal email is not affected. We appreciate your patience while the issue is being investigated.
Posted Aug 14, 2026 - 09:45 EDT
This incident affected: Email Services (Office 365 Email & Calendar).