HUIT Service Status Dashboard

Crimson Print Service is Degraded
Incident Report for HUIT
Resolved
Crimson Print Services have been restored. If you have any other Crimson Print related issues, please submit a ticket to ithelp@harvard.edu. Thank you.
Posted Sep 20, 2021 - 16:37 EDT
Investigating
Crimson Print Service is Degraded. HUIT is aware and actively investigating the problem.
Posted Sep 20, 2021 - 11:15 EDT