HUIT Service Status Dashboard

my.harvard Application is Degraded
Incident Report for HUIT
Resolved
Service has been restored for the admin.my.harvard.edu and portal.my.harvard.edu applications. A spike in the shared pool for each application led to significant performance degradation. The applications were taken offline for maintenance and we are seeing healthy performance of the applications at this time.

In some cases, you may need to clear your browser’s cache and cookies before being able to successfully access either application. Some pages may load more slowly than expected at first as cache is rebuilt in each application. Please send a report of any further issues you experience or any questions you may have to myharvard_support@harvard.edu.
Posted Jan 23, 2020 - 20:00 EST
Investigating
HUIT is investigating performance issues with my.harvard. application.
Posted Jan 23, 2020 - 17:05 EST
This incident affected: my.harvard - Enterprise Student Systems (ESS).