HUIT Service Status Dashboard

Peoplesoft is Unavailable
Incident Report for HUIT
Resolved
Peoplesoft issue is resolved.
Posted about 1 month ago. May 13, 2019 - 12:09 EDT
Investigating
PeopleSoft system is currently inaccessible. HUIT is investigating.
Posted about 1 month ago. May 13, 2019 - 12:01 EDT
This incident affected: HR Applications.