HUIT Service Status Dashboard

my.Harvard Alumni Access

Incident Report for HUIT

Identified

HUIT has identified the issue impacting alumni access to my.harvard.edu and is actively implementing a fix. Restoration is occurring on a rolling basis, and as the day continues, more alumni will regain access. Resolution is taking longer than initially anticipated and will extend beyond 4:00 PM EST. We will continue to share updates as progress is made and appreciate your patience.
Posted Mar 09, 2026 - 13:57 EDT

Investigating

HUIT is aware of an issue impacting alumni access to the my.harvard.edu. We are currently investigating the issue and expect access to be restored on a rolling basis, access expected to be restored by 4:00 pm.
Posted Mar 09, 2026 - 10:35 EDT
This incident affects: my.harvard - Enterprise Student Systems (ESS).