HUIT Service Status Dashboard

O365 Self-Service Email Activation Degradation
Incident Report for HUIT
Resolved
HarvardKey self-service for Office365 is restored. HUIT teams applied fix to Microsoft licensing to bring accounts into sync.
Posted Jun 07, 2021 - 11:11 EDT
Update
HarvardKey self-service for Office365 continues to experience degradation at this time. A fix will be deployed on Monday 6/7 by 10am.
Posted Jun 04, 2021 - 15:02 EDT
Identified
HarvardKey self-service for Office365 continues to experience degradation at this time. HUIT has identified the root cause of the issue and is working towards testing and deploying a solution.
Posted Jun 04, 2021 - 10:20 EDT
Update
HUIT continues to investigate the issue with O365 self-service email activation.
Posted Jun 03, 2021 - 17:22 EDT
Update
HarvardKey self-service for Office365 continues to experience degradation at this time. HUIT team is still investigating.
Posted Jun 03, 2021 - 14:46 EDT
Investigating
Office365 email self-service activation through HarvardKey Self-service is currently degraded. Some users who should be able to click "Activate" to opt in to an email account are not seeing that link. Troubleshooting is ongoing.
Posted Jun 03, 2021 - 09:20 EDT
This incident affected: HarvardKey (HarvardKey Authentication).