HUIT Service Status Dashboard

Mailman Service is Unavailable
Incident Report for HUIT
Resolved
Mailman service is back to normal and the issue is resolved.
Posted Mar 21, 2019 - 16:26 EDT
Investigating
HUIT is investigating issues with Mailman Service.
Posted Mar 21, 2019 - 15:47 EDT
This incident affected: Other Services.