HUIT Service Status Dashboard

HarvardKey resets and claims are degraded
Incident Report for HUIT
Resolved
HUIT teams restored HarvardKey service. Users can successfully reset passwords and no longer see Error '1003' messages.
Posted Sep 03, 2019 - 16:19 EDT
Investigating
Members of the Harvard community trying to re-set their HarvardKey password -- either see a blank page or Error Code 1003. New users trying to claim HarvardKey will see the same. HUIT teams are investigating.
Posted Sep 03, 2019 - 15:54 EDT
This incident affected: HarvardKey (HarvardKey Authentication).