HUIT Service Status Dashboard

my.Harvard Service Degradation

Incident Report for HUIT

Resolved

my.Harvard has returned to normal operations.
Posted Jan 19, 2022 - 15:48 EST

Monitoring

Between approximately 11:45 AM and 12:45 PM today, my.harvard experienced some performance issues affecting the administrative portals and course catalog. Normal service has now been restored, but we are continuing to closely monitor system performance.
Posted Jan 19, 2022 - 13:05 EST

Investigating

my.harvard services are currently degraded. HUIT is investigating the issue.
Posted Jan 19, 2022 - 12:33 EST
This incident affected: my.harvard - Enterprise Student Systems (ESS).