HUIT Service Status Dashboard

my.Harvard Performance Issue

Incident Report for HUIT

Resolved

The issue of users encountering internal server errors has been resolved, and performance has returned to normal levels. The team will continue to monitor the service while the vendor conducts a Root Cause Analysis.
Posted Jun 25, 2026 - 18:21 EDT

Monitoring

The team has made progress in troubleshooting the issue, with performance returning to normal levels. The team will continue to monitor to confirm resolution.
Posted Jun 25, 2026 - 17:36 EDT

Investigating

HUIT is aware of a performance issue impacting my.Harvard. We are currently investigating the issue and will provide updates as they become available.
Posted Jun 25, 2026 - 14:54 EDT
This incident affected: my.harvard - Enterprise Student Systems (ESS).