HUIT Service Status Dashboard

FAS Math Department Server is Unavailable
Incident Report for HUIT
Resolved
A workaround was implemented to get the server, web sites, and applications running.
Posted Jun 17, 2022 - 02:31 EDT
Investigating
The FAS Math Department Server is unavailable, HUIT teams are currently troubleshooting the issues.
Posted Jun 16, 2022 - 20:50 EDT
This incident affected: Other Services.