HUIT Service Status Dashboard

VPN authentication issues
Incident Report for HUIT
Resolved
VPN service is restored as of 3:46 PM.
Posted 3 months ago. May 19, 2019 - 16:29 EDT
Investigating
There are currently reports of trouble authenticating into VPN. Users already logged in remain logged in. HUIT is investigating.
Posted 3 months ago. May 19, 2019 - 13:59 EDT
This incident affected: Network Services.