HUIT Service Status Dashboard

HarvardSites Drupal Degradation

Incident Report for HUIT

Resolved

Functionality to HarvardSites Drupal has been restored. If you still experience issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Feb 17, 2026 - 16:47 EST

Investigating

HUIT is aware of an issue causing some HarvardSites Drupal sites to load slowly. We are currently investigating the issue and will provide updates as they become available.
Posted Feb 17, 2026 - 13:22 EST
This incident affected: Harvard Web Publishing Platforms (HarvardSites Drupal).