HUIT Service Status Dashboard

Microsoft Outlook for the Web and Plugin Issues

Incident Report for HUIT

Resolved

Microsoft has confirmed that the issue impacting Outlook on the Web, and some plugins is now resolved.
Posted Oct 29, 2025 - 19:56 EDT

Monitoring

Microsoft is reporting that some users may experience issues when accessing Outlook for the Web as well as some Outlook plugins, like Zoom. In the meantime please create meetings in Zoom directly if needed. We will provide an update when Microsoft completes their fix.
Posted Oct 29, 2025 - 13:59 EDT
This incident affected: Email Services (Office 365 Email & Calendar).