HUIT Service Status Dashboard

ServiceNow Global Search Not Working Properly

Incident Report for HUIT

Resolved

The issue impacting searching for incidents in ServiceNow should now be resolved.
Posted Jul 14, 2025 - 16:48 EDT

Investigating

The HUIT ITSM team is aware of an issue affecting Global Search in ServiceNow, where technicians are unable to retrieve incident tickets and related records as expected. We have reported this problem to the vendor and are actively working toward a resolution. We will provide updates as soon as more information becomes available.
Posted Jul 14, 2025 - 13:19 EDT
This incident affected: Service Management (ServiceNow).