HUIT Service Status Dashboard

Brass Ring Employment Site Down
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted 11 days ago. Jun 07, 2019 - 21:01 EDT
Monitoring
Currently monitoring the status of the vendor, and will update when the status changes.
Posted 11 days ago. Jun 07, 2019 - 17:52 EDT