HUIT Service Status Dashboard

Harvard Phone Portal Degradation

Incident Report for HUIT

Resolved

Access to Harvard Phone portal has been restored.
Posted Mar 16, 2025 - 17:01 EDT

Identified

The Harvard Phone portal (provisioning and voicemail changes) is currently unavailable, the Harvard Phone service is operational, inbound and outbound calls are not impacted. We are working to restore access and will provide updates as they become available.
Posted Mar 16, 2025 - 13:59 EDT
This incident affected: Telecommunication Systems.