HUIT Service Status Dashboard

O365 Service Degradation
Incident Report for HUIT
Resolved
Microsoft has restored the Office 365 service to normal operation as of 6:30PM
Posted Oct 07, 2020 - 19:07 EDT
Monitoring
Microsoft have reverted a recent change which may have led to impact to Microsoft 365 services and features. Their initial telemetry shows that services are in recovery. They will continue monitoring the environment to ensure service stability.
Posted Oct 07, 2020 - 16:13 EDT
Investigating
O365 is currently experiencing issues. We are actively investigating the problem. Please visit the HUIT Service Status Dashboard for regular updates about this situation. We apologize for the inconvenience and hope to resolve this issue soon.
Posted Oct 07, 2020 - 15:11 EDT
This incident affected: Collaboration & Sharing Services (Microsoft OneDrive, Microsoft Teams, Sharepoint).