HUIT Service Status Dashboard

Network connectivity issues affecting several buildings
Incident Report for HUIT
Resolved
Network connectivity issues in the affected buildings have been resolved.
Posted Oct 07, 2022 - 08:29 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 06, 2022 - 18:23 EDT
Investigating
Network connectivity in Conant Hall, Perkins Hall, Richards Hall, and Child Hall is currently interrupted due to a power outage.
Posted Oct 06, 2022 - 18:22 EDT