HUIT Service Status Dashboard

HMS Network Issues
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 10:52 EST
Investigating
Harvard Medical School is experiencing network issues. The problem may affect VPN as well as wired and wireless connections on campus.

They are working to fix this problem as quickly as possible and will follow up with important updates.

If you have questions or concerns, visit the HMS IT Service Portal at https://it.hms.harvard.edu/. You can also contact HMS IT by phone at 617-432-2000 or by email at itservicedesk@hms.harvard.edu
Posted Feb 05, 2024 - 09:25 EST