HUIT Service Status Dashboard

FAS Unix Mail Delivery Issues
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted 5 months ago. May 15, 2019 - 10:36 EDT
Investigating
Users of FAX Unix Mail may have noticed delays in mail delivery since yesterday. The issue is now resolved.
Posted 5 months ago. May 15, 2019 - 10:34 EDT
This incident affected: Other Services.