HUIT Service Status Dashboard

Open OnDemand Not Accessible

Incident Report for HUIT

Resolved

The problem has been resolved, and Open OnDemand services are now accessible.
Posted Oct 06, 2025 - 16:57 EDT

Identified

We've identified the issue and are actively working on remediation. Updates will be shared as progress continues toward full service restoration.
Posted Oct 06, 2025 - 14:54 EDT

Investigating

The Academic Technology team is investigating the issue of users not being able to access Open OnDemand courses.
Posted Oct 06, 2025 - 13:32 EDT
This incident affected: Other Services.