HUIT Service Status Dashboard

Proofpoint Quarantine Access
Incident Report for HUIT
Resolved
Proofpoint has resolved the issue that caused users to lose access to spam.huit.harvard.edu and service is fully restored. HUIT will continue to monitor for any issues.
Posted Mar 07, 2024 - 13:20 EST
Investigating
Proofpoint is reporting an issue that is preventing users from accessing spam.harvard.edu to manage their quarantine. Email delivery is not impacted. At this time, users cannot release email from their quarantine, block senders, or add senders to their safe list. HUIT is working with Proofpoint to resolve the issues and we will update with any changes.
Posted Mar 07, 2024 - 09:39 EST
This incident affected: Email Services (Proofpoint).