HUIT Service Status Dashboard

Buy to Pay Jaggaer Software is Unavailable
Incident Report for HUIT
Resolved
Buy to Pay Jaggaer is back on line and the issue is resolved.
Posted Jul 23, 2020 - 13:02 EDT
Investigating
Buy to Pay Jaggaer Software is Unavailable. The software vendor is working to resolve the issues.
Posted Jul 23, 2020 - 11:06 EDT
This incident affected: Financial Applications (BUY-TO-PAY Powered by JAGGAER).