HUIT Service Status Dashboard

HarvardKey self-service degradation
Incident Report for HUIT
Resolved
IAM Engineers determined that a change this morning to clean-up unused DUO configurations included configurations that were unexpectedly still in use. The change has been reverted and the necessary configuration has been labeled appropriately and restored.
Posted Aug 12, 2022 - 10:43 EDT
Investigating
HUIT has received reports of issues accessing HarvardKey self-service - including HarvardKey Claim, Manage Your Account & Services, and Reset Password or Recover Login Name. The team is investigating and will provide an update when we have more information.
Posted Aug 12, 2022 - 10:02 EDT