HUIT Service Status Dashboard

directory.harvard.edu is unavailable
Incident Report for HUIT
Resolved
Access to directory.harvard.edu has been restored.
Posted Jun 16, 2020 - 19:05 EDT
Investigating
Access to the website directory.harvard.edu has been interrupted. HUIT teams are currently investigating the issue and working to restore the website.
Posted Jun 16, 2020 - 18:01 EDT