HUIT Service Status Dashboard

Concur System Issues
Incident Report for HUIT
Resolved
Concur system services are back to normal.
Posted Jun 22, 2020 - 15:55 EDT
Investigating
Concur is currently reporting system outages. The incident is actively being investigated and status updates can be found here http://open.concur.com/#us
Posted Jun 22, 2020 - 15:13 EDT
This incident affected: Financial Applications (Concur).