HUIT Service Status Dashboard

Concur Financial System: Login/performance issues
Incident Report for HUIT
Resolved
The Concur platform has returned to normal operations.
Posted Mar 04, 2024 - 15:07 EST
Update
We have received the following update from our vendor:

"Services have returned to normal operating levels. We will continue monitoring performance for the next 15-30 minutes to verify stability. Once verified as stable the incident will be resolved."

Once they are confident in full resolution we will resolve this incident.
Posted Mar 04, 2024 - 14:21 EST
Update
An update from our vendor:

"While some recovery is observed and some users may be able to login, should an error be experienced upon login please wait 15 minutes prior to attempting another login. Some users may experience an error when attempting to complete tasks. Should an error be received while performing a task, please attempt to complete the task after a refresh.

The Incident Response Team (IRT) performed a restart. Additionally, an investigation is underway to perform a mapping update to continue stabilizing traffic. Monitoring of all systems is continuing."
Posted Mar 04, 2024 - 12:59 EST
Monitoring
Our vendor has provided the following update:

"....Recovery has been observed. However, should an error be experienced upon login please wait 15 minutes prior to attempting another login. The Incident Response Team (IRT) has engaged additional resources for monitoring and confirmation of continuing stabilization."

We will continue to post the updates provided from our vendor until they have confirmed incident resolution.
Posted Mar 04, 2024 - 10:41 EST
Investigating
We are investigating reports of login/performance issues with the Concur financial system.

https://open.concur.com/?data-center=us2
Posted Mar 04, 2024 - 10:07 EST
This incident affected: Financial Applications (Concur).