HUIT Service Status Dashboard

Athletics Area Network Interruption

Incident Report for HUIT

Resolved

The network in the athletics area has been fully restored and is now operating normally. If you continue to experience issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Apr 24, 2026 - 16:34 EDT

Identified

We’ve identified an issue within the athletics network that is affecting both wired and wireless connections. We are actively working to resolve the problem and restore service as quickly as possible.
Posted Apr 24, 2026 - 16:10 EDT
This incident affected: Network Services (Wired Networking, Wireless Networking).