HUIT Service Status Dashboard

HUIT Confluence Service Disruption

Incident Report for HUIT

Resolved

HUIT Confluence has been restored by the vendor. If you continue to experience issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Jun 16, 2026 - 10:52 EDT

Investigating

HUIT Confluence is currently unavailable due to a vendor outage affecting Atlassian Confluence. JIRA and Wiki services remain stable and are not impacted at this time.

We are monitoring Atlassian’s status page and will provide updates as more information becomes available: https://confluence.status.atlassian.com/
Posted Jun 16, 2026 - 09:54 EDT
This incident affected: Other Services.