HUIT Service Status Dashboard

OpenScholar Sites are Degraded
Incident Report for HUIT
Resolved
OpenScholar sites have returned to full functionality
Posted Mar 29, 2021 - 17:25 EDT
Monitoring
Sites appear to be coming back online. HUIT is monitoring.
Posted Mar 29, 2021 - 17:01 EDT
Investigating
HUIT is investigating degraded performance in OpenScholar sites.
Posted Mar 29, 2021 - 16:56 EDT
This incident affected: Harvard Web Publishing Platform.