HUIT Service Status Dashboard

Network is unavailable in North Precinct region
Incident Report for HUIT
Resolved
Network access in the North Precinct has been restored
Posted Mar 22, 2023 - 17:44 EDT
Investigating
Harvard community members in the North Precinct have no internet access, no email or network printing. Most immediately this impacts Divinity, Center for Government and International Studies Complex, William James Hall and University Hall. HUIT is investigating.
Posted Mar 22, 2023 - 17:26 EDT
This incident affected: Other Services.