HUIT Service Status Dashboard

[Resolved] my.harvard was unavailable
Incident Report for HUIT
Resolved
Starting at approximately 7:20 AM users reported an error while trying to log in to admin.my.harvard.edu. HUIT teams worked with SCI vendor to resolve service as of 8:52 AM.
Posted about 1 month ago. Jun 18, 2019 - 09:14 EDT
This incident affected: Teaching & Learning Platforms (Enterprise Student Systems (ESS)).