HUIT Service Status Dashboard

Certificate issue when visiting some Harvard websites
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Jan 18, 2022 - 21:27 EST
Update
We are continuing to investigate this issue.
Posted Jan 18, 2022 - 20:44 EST
Update
We are continuing to investigate this issue.
Posted Jan 18, 2022 - 20:03 EST
Investigating
Anyone logging into OpenScholar websites may be presented with a certificate issue. HUIT is working closely with OpenScholar to identify a solution.
Posted Jan 18, 2022 - 19:42 EST
This incident affected: HR Applications (Harvard Careers, Aurora HR) and Harvard Web Publishing Platform.