HUIT Service Status Dashboard

Canvas Degradation

Incident Report for HUIT

Resolved

Access to Canvas has been restored. If you continue to experience login issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Jul 16, 2026 - 08:30 EDT

Monitoring

HUIT is investigating reports of issues accessing Canvas. Service appears to be recovering, but some users may still experience intermittent issues. We will continue to monitor and provide updates as they become available.
Posted Jul 16, 2026 - 07:27 EDT
This incident affected: Canvas.