HUIT Service Status Dashboard

Issues with WebEx (VOIP) calling

Incident Report for HUIT

Resolved

As of 10:15 Cisco has implemented a fix for the issue widely impacting VOIP phone service across campus including WebEx softphones and desk phones. All impacted services are now restored.

HUIT will continue to monitor our VOIP / Webex Phone services to ensure stability. If you experience any unexpected service issues, please contact your local service desk or the HUIT Service Desk (617-495-7777 or ithelp@harvard.edu).
Posted Jun 04, 2025 - 11:04 EDT

Identified

Our vendor, Cisco, has identified the issue widely impacting VOIP phone service across campus including WebEx softphones and desk phones. We are beginning to see restoration of services.

We are actively working with our vendor to restore all remaining services. Emergency lines are working across Harvard. If you need technical support please open a ticket via the IT service portal (https://harvard.service-now.com/ithelp) or use live agent chat.
Posted Jun 04, 2025 - 10:14 EDT

Update

Our vendor, Cisco, is experiencing broad service issues with VOIP (WebEx) impacting phone calls. We have opened a priority ticket to restore services.

Emergency lines are working across Harvard. If you need technical support please open a ticket via the web (https://harvard.service-now.com/ithelp) or use live agent chat.
Posted Jun 04, 2025 - 09:16 EDT

Investigating

We are experiencing issues with VOIP (WebEx) services that are impacting VOIP calls. Customers are also unable to log into the self-service phone portal. Emergency lines are working across Harvard. Our vendor has indicated that there is a broader WebEx issue occurring and we have opened a priority ticket to restore services.
Posted Jun 04, 2025 - 08:52 EDT
This incident affected: Telecommunication Systems.