HUIT Service Status Dashboard

Harvard Key Authentication is Degraded
Incident Report for HUIT
Resolved
Harvard Key authentication services are back to normal as of 4:30PM and the issue is resolved.
Posted Jun 23, 2020 - 17:49 EDT
Investigating
HUIT is investigating Harvard Key authentication issues due to issues with Group Services.
Posted Jun 23, 2020 - 16:13 EDT
This incident affected: HarvardKey & Duo (HarvardKey).