HUIT Service Status Dashboard

HUIT Exchange web console is unreachable
Incident Report for HUIT
Resolved
HUIT teams have discovered the expired Certificate that led to this outage. Service has been associated to a valid Certificate to restore normal operations.
Posted Jun 21, 2022 - 12:21 EDT
Investigating
Exchange Admins are unable to reach the on-prem Exchange console. This does not affect Exchange Online users' ability to use email, but changes to mailboxes are delayed as a result.
Posted Jun 21, 2022 - 11:05 EDT
This incident affected: Email Services (Office 365 Email & Calendar).