HUIT Service Status Dashboard

Some users may encounter issues accessing Harvard M365 accounts

Incident Report for HUIT

Resolved

The Okta refresh cycle has been completed which has resolved this incident. If you are still encountering issues accessing your Harvard M365 account, please contact the Help Desk at ithelp@harvard.edu or (617) 495-7777.
Posted Feb 26, 2025 - 17:10 EST

Identified

HUIT is currently performing a system upgrade from Duo to Okta. As a result, some users may encounter issues accessing their Harvard M365 accounts.

If you encounter an issue logging into M365 (Teams, Outlook, Powerpoint, Excel, Word, Sharepoint) please use Outlook on the Web (https://www.outlook.com/harvard.edu ). If issues persist please contact the Help Desk at ithelp@harvard.edu or (617) 495-7777.
Posted Feb 26, 2025 - 06:00 EST
This incident affected: Email Services (Office 365 Email & Calendar).