HUIT Service Status Dashboard

Microsoft 365 Issues Affecting Sending and Receiving Emails

Incident Report for HUIT

Resolved

Microsoft has confirmed the incident was resolved early this morning. Our external email queues are now clear, indicating that messages from outside Harvard are being delivered successfully. If you continue to experience login issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu
Posted Jan 23, 2026 - 07:40 EST

Update

Microsoft is indicating that a fix is in place, it is taking time to propagate.  Harvard is still experiencing delays in receiving and sending emails. This is an issue impacting all of North America.
Posted Jan 22, 2026 - 20:16 EST

Update

Microsoft is continuing to work to restore service; however, Microsoft 365 services (including Outlook, Teams, and OneDrive) are still experiencing issues. We expect an additional update from Microsoft soon.
Posted Jan 22, 2026 - 18:45 EST

Monitoring

Microsoft has reported that it has restored the affected infrastructure; however, services are not yet fully recovered.
You may experience delays receiving Outlook emails from senders outside of Harvard.
We are continuing to monitor and will post more information as it becomes available from Microsoft.
Posted Jan 22, 2026 - 17:15 EST

Investigating

Microsoft has confirmed broad issues with M365. We are actively working with Microsoft to remediate this issue. We will provide an update as we learn more.
Posted Jan 22, 2026 - 16:31 EST
This incident affected: Email Services (Office 365 Email & Calendar) and Collaboration & Sharing Services (Microsoft OneDrive, Microsoft Teams, Sharepoint).