HUIT Service Status Dashboard

Canvas Service Degradation
Incident Report for HUIT
Resolved
Canvas has implemented a fix and the issue was resolved.
Posted Mar 25, 2021 - 11:03 EDT
Update
Canvas has implemented a fix and the incident should be resolved. HUIT is monitoring.
Posted Mar 25, 2021 - 10:30 EDT
Update
Most users are now able to access Canvas, but you may experience performance issues as Canvas continues to fix the root cause of the initial outage.
Posted Mar 25, 2021 - 10:03 EDT
Identified
We are seeing users start to get back in to Canvas. HUIT is monitoring.
Posted Mar 25, 2021 - 09:20 EDT
Investigating
Canvas is currently experiencing issues. HUIT is aware and actively investigating the problem.
Posted Mar 25, 2021 - 08:49 EDT
This incident affected: Canvas.