HUIT Service Status Dashboard

my.Harvard Service Degradation
Incident Report for HUIT
Resolved
my.Harvard continues to operate as normal and HUIT is still monitoring the service. If you are still experiencing issues logging on and using the course search feature please reach out to the HUIT Service Desk.
Posted Sep 08, 2021 - 13:05 EDT
Update
At 11:07 AM, HUIT received reports that the my.harvard portal was experiencing degraded performance affecting user log in and course search. These issues continued for approximately 15-20 minutes. My.harvard is currently operating as normal, but we will continue to monitor the system closely throughout the day. Please report any further issues to the HUIT Service Desk.
Posted Sep 08, 2021 - 12:11 EDT
Monitoring
As of 11:07 AM, HUIT received reports that the my.harvard portal was experiencing degraded performance affecting user log in and course search. These issues continued for approximately 15-20 minutes. We will continue to monitor the system closely throughout the day. Please report any further issues to the HUIT Service Desk.
Posted Sep 08, 2021 - 11:48 EDT
This incident affected: my.harvard - Enterprise Student Systems (ESS).