HUIT Service Status Dashboard

Harvard University Websites experiencing issues loading

Incident Report for HUIT

Resolved

The incident impacting university websites has been resolved.
Posted Sep 14, 2023 - 16:25 EDT

Monitoring

The solution provided by our vendor is in place and previously impacted websites are available again. HUIT will continue to monitor the situation and resolve this incident once we have returned to normal operations.

Vendor Status Page:
https://status.pantheon.io/
Posted Sep 14, 2023 - 14:43 EDT

Identified

Our vendor has identified the root cause of the outage and is implementing a fix to restore access to impacted university websites. We will continue to provide updates here as they become available.

Vendor Status Page:
https://status.pantheon.io/
Posted Sep 14, 2023 - 14:01 EDT

Investigating

HUIT is investigating reports of outages impacting Harvard University websites. We will provide updates as more information becomes available.

Visitors to websites will encounter "Page Could Not Be Loaded" error message.
Posted Sep 14, 2023 - 13:44 EDT
This incident affected: Other Services.