HUIT Service Status Dashboard

iThenticate service unavailable

Incident Report for HUIT

Resolved

The iThenticate service issue has been resolved and is now operational.
Posted Jun 10, 2025 - 07:53 EDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2025 - 18:28 EDT

Investigating

iThenticate functionality is currently unavailable. We are aware of the issue and are working with the vendor to resolve this.
We apologize for the disruption and thank you for your patience.
Posted Jun 09, 2025 - 18:28 EDT
This incident affected: Other Services.