Access to my.Harvard is beginning to be restored. The underlying issue has been identified, and the system is being closely monitored to ensure continued stability. If you continue to experience login issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Mar 31, 2026 - 11:48 EDT
Update
We are continuing to investigate access issues affecting my.harvard. Course materials remain available and can be accessed via canvas.harvard.edu. We will provide updates as additional information becomes available.
Posted Mar 31, 2026 - 10:23 EDT
Investigating
We are currently receiving reports that my.Harvard is inaccessible, with users unable to log in. We are actively investigating and will provide updates as more information becomes available
Posted Mar 31, 2026 - 08:54 EDT
This incident affected: my.harvard - Enterprise Student Systems (ESS).