HUIT Service Status Dashboard

HarvardSites Loading Issue

Incident Report for HUIT

Resolved

The issue impacting some university websites has been resolved.

Please contact the HUIT Service Desk if you continue to experience issues loading websites - (617)495-7777 or email ithelp@harvard.edu
Posted Oct 30, 2025 - 15:17 EDT

Investigating

HUIT is investigating an intermittent issue affecting access to some (less than 50) sites running on the HarvardSites platform.

As of this notice, this issue is only impacting individuals who are on Harvard campus networks and visiting a bare domain. A suggested temporary workaround is to advise the user to add “www.” to the url. e.g. www.huit.harvard.edu
Posted Oct 30, 2025 - 13:20 EDT
This incident affected: Harvard Web Publishing Platforms (HarvardSites Drupal).