HUIT Service Status Dashboard

New Quizzes Access Error

Incident Report for HUIT

Resolved

Access to New Quizzes has been restored. If you continue to experience issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Mar 30, 2026 - 16:03 EDT

Identified

We are aware of an issue affecting New Quizzes in Canvas. Users attempting to access this feature may encounter a 502 error and may not be able to view or take the quiz. The vendor is working on a fix and we will provide updates when they become available.
Posted Mar 30, 2026 - 11:58 EDT
This incident affected: Canvas.