HUIT Service Status Dashboard

Kiteworks Secure File Transfer Outage
Incident Report for HUIT
Resolved
We have restored the Kiteworks secure file tranfer service to normal operations.
Posted Mar 12, 2024 - 13:56 EDT
Investigating
Kiteworks is currently down. The HUIT team is investigating and expects to have it back up and running shortly. We would like to remind M365 email users that the Microsoft Office Message Encryption service (OME) is available for use. OME allows you to send encrypted emails and files up to 150MBs in size, supporting data up to Level 4 classification. To get started with OME, please review our helpful "Send an Encrypted Email in Outlook" knowledge article.
Posted Mar 12, 2024 - 13:47 EDT
This incident affected: Collaboration & Sharing Services (Secure File Transfer).