HUIT Service Status Dashboard

HarvardKey Login Issue
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 17:00 EST
Identified
HarvardKey logins have been restored. We will continue to monitor to ensure stability before resolving this incident.
Posted Feb 22, 2024 - 15:57 EST
Investigating
We are investigating an issue impacting HarvardKey logins. Attempting to login to websites or applications behind HarvardKey yields a "504 Gateway Time-out" error.
Posted Feb 22, 2024 - 15:36 EST
This incident affected: HarvardKey (HarvardKey Authentication).