HUIT Service Status Dashboard

Verizon Mobile Network Outage

Incident Report for HUIT

Resolved

Verizon announced that the issue has been resolved and recommended that customers who continue to experience difficulties restart their devices.
Posted Jan 16, 2026 - 14:33 EST

Monitoring

A nationwide Verizon mobile network outage is impacting voice, text, and data for customers. Harvard systems are not impacted at this time; however individuals with Harvard-provided mobile devices on the Verizon network may be affected.
Posted Jan 14, 2026 - 14:13 EST
This incident affected: Telecommunication Systems.